Cannot access Blackbaud products in Internet Explorer since SSO

A few of my colleagues as well as myself can not access Blackbaud products in Internet Explorer since Single Sign On took place. This is a problem because we need to access our Blackbaud product in Internet Explorer to run daily tasks. We are getting an error message that says: 
Oops! Something went wrong. Make sure cookies are enabled, and sign in again. 

Alternatively, you may see a message on the Blackbaud ID screen that says: Check the email address or password for typos, or select 'Sign in with Google' below. However, you are able to log in to Chrome with the same username and password. 
  1. Ensure you have Java and JavaScript enabled in your browser.
  2. Ensure cookies are enabled in the browser
  3. Add the following URL's to your Trusted Sites in your browser
  • signin.blackbaud.com  
  • blackbaudinc.auth0.com  
  • sky.blackbaudcdn.net  
  • s21aidntoken00blkbapp01.nxt.blackbaud.com
  • login.blackbaudondemand.com
  • https://*.blackbaud.com
  • bbid.blackbaud.com
  1. Please try clearing browser cache, cookies, and temporary Internet files, close the browser, and then sign in again. 
  2. Make sure you have the correct TLS settings
    • In Internet Explorer, click tools in the upper right hand corner of the screen
    • Click Internet Options
    • Click on the Advanced tab and scroll to the bottom of the settings section
    • Make sure Use TLS 1.0, Use TLS 1.1, and Use TLS 1.2 are all marked
    • Click Apply
    • Click OK
If you continue to run into this issue after following those steps please chat with support and reference this article

Environment

 Altru Arts & Cultural

Was this article helpful?