Compatibility should be set to SQL 2005 (90) or above. Compatibility levels higher than 90 are supported.