The RE7Service or REWS acts as a web service facade to The Raiser’s Edge API. You must install the RE7Service web service(REWS) on a machine that has The Raiser’s Edge client installed and properly configured to connect to the database in The Raiser’s Edge. Because this service must access Raiser’s Edge database, we recommend you install it on a distinct machine on the intranet side of a DMZ.

Pre-Installation Considerations:

  • Raiser's Edge and/or Education Edge workstation client must be installed, working, and must match the current version of RE/EE running on your SQL server. Please login to Raiser's Edge/Education Edge on the web server and ensure the application is updated and there are no errors.
  • Determine the Blackbaud NetCommunity version and patch that you will update to. Generally, this will be the newest available version and patch. DO NOT attempt to install a newer version or patch to your Raisers Edge Web Server than the version and patch that are currently installed to your NetCommunity servers and components that are hosted by Blackbaud Hosting Services.
  • Review the Blackbaud NetCommunity System Requirements for Operating system and Hardware requirements. 
    • If Blackbaud hosts your Blackbaud NetCommunity database, the resources discussed in the sections Blackbaud NetCommunity database server and Blackbaud NetCommunity web server & core components are managed by Blackbaud.
      • If Blackbaud Hosting Services has already updated your NetCommunity database, web server, and core components to the newest version and patch, and all components are already running NetCommunity version 6.41 or higher, proceed with the update to your Raiser's Edge Web Server.
      • If Blackbaud Hosting Services has not already updated your NetCommunity database, web server, and core components to the newest version and patch, or your installation is still running NetCommunity version 6.40 or below, please contact Support to discuss your specific installation before proceeding.
  • Make a backup of the Raiser's Edge WebService web.config file if you are migrating the REWS server. If you are new to NetCommunity please see install steps below.
  • Install Microsoft IIS and enable the following roles and services
  • Please install and map a SSL certificate for the REWS domain in question if you are planning on allow secure traffic through port 443. if you have any questions on installing or binding the SSL in Microsoft IIS please see your SSL authority or server admin. 
  • NetCommunity will only talk to a single Raiser's Edge database, if you have multiple RE databases attached please consider what database is to be used.
  • To secure this service from Internet users, you can install the REWS on a web server that is not visible to the public Internet. If that is not possible, you can configure the site to use a port other than port 80, then configure the firewall accordingly. The site can also be configured to disallow anonymous access. To further enforce this, configure the IIS virtual directory to allow access from only the necessary IP addresses (Blackbaud NetCommunity web servers, services servers, and The Raiser’s Edge workstations). Even if REWS is installed on a machine on the intranet side of the DMZ, access to this service should still be limited. This can be done either with firewall policy or via IIS IP Address security or IPSec.
  • (Recommended): Process all existing transactions out of the NetCommunity plugin in Raiser's Edge.

What software download do I use?

You will use the NetCommunity blackbaudinstallerXXX.exe. The file is used for installing REWS and the full NetCommunity package. During the install steps we will be using the REWS features only. A brief explanation of the installer files available in the NetCommunity section of 
  • blackbaudinstallerXXX.exe (where XXX = the version of NetCommunity, i.e. blackbaudinstaller70144.exe) - When split-hosted, this file is used to update the the Raiser's Edge Web Server to Patch 0 of the version specified.
  • pluginXXX.exe (where XXX = the version of NetCommunity and YY - the Patch number, i.e. plugin70144patch2.exe) - this workstation-specific installer is used to install or update the NetCommunity plugin.  Note that this must be run on each workstation that needs to download data from NetCommunity into The Raiser's Edge or The Education Edge/BBSIS.  Note: this file should never be run on the NetCommunity Server or Raiser's Edge Web server.  Doing so will render NetCommunity unavailable until the NetCommunity components are uninstalled and reinstalled.

Steps to Install/Migrate

  1. Configure the new server to meet all requirements for The Raiser's Edge Web Services. The system requirements for The Raiser's Edge Web Service server need to be met in order for the server to work properly. See our pre-installation recommendations above.
  2. IF you are migrating servers, on the old server, open the Raiser's Edge Web Service web.config file and locate the RE7ServiceUsers credentials. Make note of the username\password next to value=.
    • Example: <add key="RE7ServiceUsers" value="username\password" />.
    • You'll need these for the new install. If the credentials are not entered exactly, the connection to the web components won't be successful.
  3. Download the necessary file from the downloads page from the NetCommunity link. Browse to the executable file you downloaded and launch the installer on the new REWS server.
  4. You will be prompted to enter a Site ID an Email address, mark the box to continue without credentials and click next. The Site ID and email address are not needed for the REWS.User-added image
  5. Select the proper components, make sure The Raiser's Edge Web Service and Raiser's Edge plugin as well as Education Edge plugin if you use Education Edge or Student Information Systems and click Next. If these options do not show please review the pre-installation steps above and retry.
    User-added image
  6. Update the External URL for the service, please do not leave the default:
    • If you are migrating servers, enter the existing URL for the REWS. If you do not know the existing URL see step 11 below to access the URL. If the service is down please contact Support for the information.
    • If you are installing a new server, enter the external URL for the server that your Network/IT team has decided on that can be accessed outside your organization on ports 80/443 by Blackbaud's servers. 
    User-added image
  7. Enter the password from Step 2 above into both fields and click Next. If you are installing a new server, please enter a secure password and then contact Support and reference this article after the install is complete. 
    User-added image
  8. Confirm the components are correct and click Next.
    User-added image
  9. Allow the installer to run until finished; then click Next. Note: if there are error(s) during the upgrade see next step.
    User-added image
  10. Next step is to close the upgrade window. If there where any errors during the install please search Knowledgebase for the specific error message and resolution; then retry the install again. If you still need assistance Click Chat with Support and reference this article. Please be prepared to share the error log and screenshots. To save the log, open the .txt file by clicking View Installation Log, and save the file.
    User-added image
  11. Configure the SSL certificate on the server if you have not done so already if you are allowing secure traffic through a domain; review the pre-installation steps above.
  12. Configure the DNS of the REWS so that it resolves to the IP address for the new REWS server.
    • To confirm the URL of the REWS:
    • Note: these steps will not work if the connection between REWS and BBNC is not functioning
      1. Log in to the NetCommunity website
      2. Navigate to Administration > Sites and settings > Web services
      3. Confirm the URL Listed under The Raiser's Edge settings